ecran noir après envol

Forum général de Fly! 1/2K & Fly! II (Français/English)

Modérateur : Bureau

Répondre
ROBIN
Messages : 61
Enregistré le : mercredi 10 août 2005 - 22:27
Code OACI : LFRT
Localisation : ST BRIEUC

ecran noir après envol

Message par ROBIN » lundi 28 juil. 2008 - 21:43

avec le message suivant:

unable to load aicraft model b737 shad.acm line 226 .

UNE SOLUTION ?

Avatar du membre
Robert51
Messages : 1623
Enregistré le : vendredi 14 juin 2002 - 14:35
Localisation : LFPO-Orly ex LFMN-Nice
Contact :

Re: ecran noir après envol

Message par Robert51 » mardi 29 juil. 2008 - 10:16

Pourrais-tu préciser ton aérodrome de départ, ton avion ?
Robert51 (comme le pastis, publicité non payée !) Image
ASUS Intel Core i5 à 2.8GHz, 4Go RAM, Nvidia GT620 1Go de RAM - Toshiba Portege R930 Intel Core i5 SSD - iMac 22" - Tablette Samsung Galaxy Tab 2 7'

ROBIN
Messages : 61
Enregistré le : mercredi 10 août 2005 - 22:27
Code OACI : LFRT
Localisation : ST BRIEUC

Re: ecran noir après envol

Message par ROBIN » mardi 29 juil. 2008 - 11:27

Bonjour Robert,
soit de lfpg où lfrt
dans l'attente de te lire
la config est: installation du dvd N°2 AVEC XP sp2

Avatar du membre
Robert51
Messages : 1623
Enregistré le : vendredi 14 juin 2002 - 14:35
Localisation : LFPO-Orly ex LFMN-Nice
Contact :

Re: ecran noir après envol

Message par Robert51 » mercredi 30 juil. 2008 - 21:29

Comme je ne suis plus chez moi, je n'ai pas Fly pour vérifier ce qu'il manque. Mais ca me fait penser à la scène de Beauvais dans laquelle il y a un 737 en décor.
Robert51 (comme le pastis, publicité non payée !) Image
ASUS Intel Core i5 à 2.8GHz, 4Go RAM, Nvidia GT620 1Go de RAM - Toshiba Portege R930 Intel Core i5 SSD - iMac 22" - Tablette Samsung Galaxy Tab 2 7'

ROBIN
Messages : 61
Enregistré le : mercredi 10 août 2005 - 22:27
Code OACI : LFRT
Localisation : ST BRIEUC

Re: ecran noir après envol

Message par ROBIN » jeudi 31 juil. 2008 - 10:16

Bon, je reinstalle tout et ...
@+

sim
Messages : 6
Enregistré le : mercredi 11 juin 2008 - 17:03
Code OACI : CYUL
Localisation : Laval, Québec

Re: ecran noir après envol

Message par sim » vendredi 1 août 2008 - 21:30

Bonjour,

Peut-être pourrais-je contribuer quelque peu à ce problème vu que j'ai exactement le même symptôme que Robin (à défaut d'environ une fois sur deux.) Je soupçonne que ce soit plutôt dû au fait que Fly charge aléatoirement le 737 comme appareil AI au démarrage. Mon param de traffic et à 10 appareils (mettre ce param à 0 réglerait peut-être ce prob?)

Voici mes observations:
- Je démarre Fly par le raccourci (flystart) créé par la procédure l'installation typique.
- J'use des fly.ini et render.ini fournis par l'installation (je n'ai pas encore testé en supprimant/réinitialisant le render.ini.)
- Mes propriétés d'affichage sont: 1024X768x32bpp & DX8 T&L (ou bien DX8 seulement; pas de diff.) sur ATI X1650, RAM 32MB+, textures détaillées <=- voila peut-être un indice...
- Mes options de décors sont toutes "maxés" (Est-ce que ça pourrait être causé par l'option "carte de l'environnement"?)
- L'appareil choisi semble peut importer peux (j'ai surtout expérimenté avec le Kodiak)
- L'aéroport choisie semble peut importer aussi (j'ai surtout expérimenté avec LFMN)

Au départ, j'ai cru à un problème du shader causé par l'usage de DX8 T&L, mais j'ai toujours le prob même avec DX8 simplement.

Voici la sortie du gtfo.txt pour ce prob:
----------------------------------------------------------------
Msg: Unable to load aircraft model : B737shad.acm
File: AMODEL.CPP line 226
Time: Thu Jul 24 12:08:21 2008
errno = 2 (No such file or directory)
----------------------------------------------------------------

Et voici la sortie du gtfo.txt pour un autre prob similaire sous les mêmes conditions:
----------------------------------------------------------------
Msg: Unable to load aircraft model : s340SHAD.acm
File: AMODEL.CPP line 226
Time: Thu Jul 24 11:59:13 2008
errno = 2 (No such file or directory)
----------------------------------------------------------------

À la vue de mon hypothèse, y as-t-il moyen d'exclure le 737 et le Saab 340 de la liste des appareils AI?

J'espère que ma contribution apportera quelque chose.

S'lu!

Avatar du membre
Didier_LFRS
Messages : 1682
Enregistré le : lundi 3 juin 2002 - 07:09
Localisation : Nantes - France (LFRS)
Contact :

Re: ecran noir après envol

Message par Didier_LFRS » dimanche 3 août 2008 - 11:18

Merci pour ton aide Sim mais ce qui est curieux c'est que les AI (sous entendu ceux réservé à SquawkBox) ont des fichiers préfixés par _AI- soit _AIS340A.ACM par exemple (voir le contenu du fichier SquawkBox_AI.pod dasn ..\Aircraft).

Je retrouve les deux fichiers incriminés plus haut dans mon installation de Fly! (celle que j'ai depuis des années mais pas tout à fait celles du DVD2 qu'il faudra bien que j'installe par ailleurs) dans des avions que j'ai installé à savoir le 737 (AirFrance7375.pod, Boeing 737-500 V20.pod et EASYJET737.EPD) et le SAAB (saab340_beta2.POD).
Ils ne font pas parti du DVD 1 ou 2 (je ne les vois pas dans les fichiers d'installation des DVD.. Je me demande s'ils n'auraient pas été utilisés comme avions de décor si cela est possible ?

Avez vous tous les deux une installation du DVD1 ou 2 sans autres ajouts, c'est à dire telle que brut d'installation ?
Je vais installer le DV2 pour voir dès que j'aurais le temps.

Bon WE
Intel Core i5-2320 Quad CPU 3.0GHz - Mem 8 Go - Windows 8 64 bits
Carte NVidia GeForce GTX 650 Mem 2 Go avec 2 écrans ( 24" + 19" )

ROBIN
Messages : 61
Enregistré le : mercredi 10 août 2005 - 22:27
Code OACI : LFRT
Localisation : ST BRIEUC

Re: ecran noir après envol

Message par ROBIN » dimanche 3 août 2008 - 21:29

Bonjour Didier,

en ce qui concerne mon installation dvd2 et rien d'autres.
@+
robin

sim
Messages : 6
Enregistré le : mercredi 11 juin 2008 - 17:03
Code OACI : CYUL
Localisation : Laval, Québec

Re: ecran noir après envol

Message par sim » mardi 5 août 2008 - 18:46

Bonjour Didier,

Idem de mon côté: Une installation fraîche suivie du DVD 1 & 2, en suivant précisément les indications fournies avec les DVDs.

Cela-dit, et après seconde réflexion, je réalise que mon hypothèse ne tient pas tout à fait debout du fait que ce ne sont PAS des appareils pilotables/dynamiques, donc nécessairement statiques. Je crois toutefois que tu détiens vraisemblablement la réponse au problème.

Ce qui m'amène à un autre point... J'ai aussi remarqué que j'ai une entrée intitulée simplement "Boeing" dans Flystart. Or, cette entrée ne semble pas correspondre à aucun appareil de la liste "interne" des avions dans Fly!. Qui plus est, j'ai encore le même problème de plantage au chargement (mais là, à tout coup!) lorsque je sélectionne la dite entrée. Au départ, j'ai "quasiment" cru (avec un soupçon d'espoir, cela-dit) que j'avais affaire aux maintenants déchus et improcurables Boeings de PDMG :cry: Hélas, non! :arrow:

Serait-ce peut-être le 747SP de Jean Sabatier?! 747 qui, autrement, semble être absent de la liste? Tout comme le ULM de Kaiser(?). Ce sont pourtant deux appareils que je croyais "parrainés" par le ROTW?! P.S.: Ne pas interpréter cette intervention comme une critique!

Bon... J'en ais assez dit...

S'lu!

Avatar du membre
Didier_LFRS
Messages : 1682
Enregistré le : lundi 3 juin 2002 - 07:09
Localisation : Nantes - France (LFRS)
Contact :

Re: ecran noir après envol

Message par Didier_LFRS » jeudi 7 août 2008 - 09:41

Bonjour à tous,

En l'absence des experts du DVD2, j'ai fouillé dans tous les fichiers et en dehors de SquawkBox aucune allusion à ces deux avions.
Et impossible de reproduire cet incident avec le DVD1+DVD2 sur mon PC.
Utilisez vous cette dll (SquawkBox ) ? On peut l'utiliser simplement pour avoir la météo en temps réel.
En attendant mieux je vous propose de la retirer provisoirement pour test. Allez dans le répertoire de votre installation de Fly dans ../modules/pc. Soit vous déplacez, soit vous renomez la dll suivante : SquawkBox.dll. Selon le paramétrage de votre PC l'extension dll peut être cachée.

Didier
Intel Core i5-2320 Quad CPU 3.0GHz - Mem 8 Go - Windows 8 64 bits
Carte NVidia GeForce GTX 650 Mem 2 Go avec 2 écrans ( 24" + 19" )

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités